Start a new topic

Beacons not registering


I've ordered 3 beacons which have arrived, however I can't find them when I use the iOS app, via the "Configure Demo" option.

4 people have this problem


Please ensure the following:

  • Your phone's bluetooth is on
  • Location Services are enabled and you have given "Always" access to Beaconstac app. You can check this in the Settings app under Privacy>Location Services
  • Your beacons are powered up. If they have battery inside and you go to My Beacons section on your app, it should show you the 3 beacons with their respective RSSI value

I make my first steps...and deleted accidentally one of the beacons. Where can I find it and recover that or find it. I miss the codes/numbers of that beacon.



I am still awaiting your comment/what to do? etc.

With regards,

Fons van den Hout

P.S. see also my mail of today.


We have already responded to you separately.  

Email used to place order doesn't let me into app.
Fixed - email is case sensitive. How can I reset my admin password without knowing the old password?

Hi Chris,

You would've received your temporary password in an email titled - Welcome to Beaconstac Eddy! (on May 29th). Do let me know if you are unable to find it.


Hi l recently bought the starter kit and the application cannot find the beacons when l search for them. l can see them under the my beacons section of the app but l cannot seem to configure them using the Androind app. l have tried using a different phone as the Xoeria Z3 Compact has been noted to have some issues with picking up the beacons but they will still not configure. Please assist

I'm attempting to connect to my beacons from the IOS App. The bluetooth is on and Location services are on "Always", but the app just continues to report "searching for this beacon" I have the Sensoro Smartbeacon Pro. My goal is to adjust the range. How to I resolve this?

Login or Signup to post a comment